Raymarine 6001 Autopilot

GPS, Sonor, Radar, Fish Finder, etc. Discuss electronics installation and upgrades.
Post Reply
Paddy
Supporting Member
Supporting Member
Posts: 176
Joined: Thu May 16, 2013 3:04 pm
Home Port: Freeport, NY

Sun Nov 03, 2019 9:14 am

Unit stopped working. Head unit goes into AUTO mode and knows that I am off course but still have full steering control, not spinning freely. I checked the smartpilot unit, fuses are good. Took a look at the pump, power is there but no sounds whatsoever. Assuming its the pump but would love feedback first.

Thanks
Rob

2004 28TE

User avatar
Tree
Gold Member
Gold Member
Posts: 1270
Joined: Fri Mar 22, 2013 12:28 pm
Home Port: Portsmouth, UK
Location: Bordon, UK
Contact:

Sun Nov 03, 2019 1:11 pm

Sounds like a check valve has gone in the pump. I buy mine direct from the manufacturer here in the UK ( simrad, Raymarine and furuno all use the same pump) they’re called hypro and I’m sure you can swap out the valves.
Fisher Price 2
Hull Number AUL28489L900
Yanmar 6LP-STE
Built in Portsmouth RI, USA - Berthed in Portsmouth Hampshire, United Kingdom.

Paddy
Supporting Member
Supporting Member
Posts: 176
Joined: Thu May 16, 2013 3:04 pm
Home Port: Freeport, NY

Sun Nov 03, 2019 2:23 pm

Thanks Tree, I will give that a shot first. Pump looks good so I would rather not part with $500+ for a new one.
Rob

2004 28TE

Post Reply

Return to “Electronics”

  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest